Вопрос задан 15.07.2023 в 02:17.
Предмет Информатика.
Спрашивает Исламов Тимур.
На входе программы имеется натуральное число n (n > 99). В числе n нужно обменять местами цифры
сотен и единиц. Входные данные #1 512 Выходные данные #1 215 Программа для паскаля!!Ответы на вопрос
Отвечает Тимеркаева Ангелина.
var
n: integer;
begin
readln(n);
writeln((n div 1000) * 1000 + (n mod 1000 mod 10) * 100 + (n mod 1000 mod 100 div 10) * 10 + (n mod 1000 div 100))
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот пример программы на Pascal, которая выполняет обмен местами цифр сотен и единиц в заданном числе:
pascalprogram SwapDigits; var n, hundreds, units, tens: integer; begin // Ввод числа n writeln('Введите число n (n > 99): '); readln(n); // Проверка условия n > 99 if n <= 99 then begin writeln('Число должно быть больше 99.'); exit; // Завершение программы end; // Получение цифр числа hundreds := n div 100; // Получение цифры сотен tens := (n div 10) mod 10; // Получение цифры десятков units := n mod 10; // Получение цифры единиц // Обмен цифрами сотен и единиц n := units * 100 + tens * 10 + hundreds; // Вывод результата writeln('Результат: ', n); end.
Пожалуйста, обратите внимание, что это пример программы на языке Pascal, который можно использовать для выполнения данной задачи.
Похожие вопросы
Информатика 12
Информатика 45
Информатика 345
Информатика 95
Информатика 27
Информатика 42
Информатика 157
Информатика 24
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
