
Вопрос задан 15.07.2023 в 01:49.
Предмет Информатика.
Спрашивает Меладзе Дана.
Pascal abc. Составьте программу, которая позволяет вывести на экран первое слово строки,
состоящей из двух слов, разделенных пробелом. Строка вводитсяс клавиатуры.

Ответы на вопрос

Отвечает Ланская Мария.
var
k: integer;
s: string[50];
begin
Readln(s);
k := Pos(' ', s);
Writeln(Copy(s, 1, k - 1))
end.



Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот пример программы на языке Pascal ABC, которая позволяет вывести на экран первое слово из строки, состоящей из двух слов, разделенных пробелом. Ввод строки осуществляется с клавиатуры:
pascalprogram FirstWordFromString; var inputString: string; firstWord: string; spaceIndex: integer; begin writeln('Введите строку, состоящую из двух слов, разделенных пробелом:'); readln(inputString); spaceIndex := pos(' ', inputString); // Находим индекс пробела if spaceIndex > 0 then begin firstWord := copy(inputString, 1, spaceIndex - 1); // Извлекаем первое слово writeln('Первое слово: ', firstWord); end else writeln('Введенная строка не содержит двух слов, разделенных пробелом.'); readln; end.
Программа запрашивает у пользователя ввод строки и ищет первое вхождение пробела в строке с помощью функции pos
. Если пробел найден, то с помощью функции copy
извлекается первое слово и выводится на экран. Если пробел не найден, выводится сообщение об ошибке.


Похожие вопросы
Топ вопросов за вчера в категории Информатика

Информатика 565

Информатика 25

Информатика 22

Информатика 27

Информатика 34

Информатика 58

Информатика 63

Информатика 23
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili