Вопрос задан 15.07.2023 в 00:05. Предмет Информатика. Спрашивает Алексеева Вероника.

Написать программу, которая будет давать следующий результат А ВВ ССС DDDD EEEEE (С помощью

Паскаля оператор while)
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Андреев Сергей.

Ответ:

package com.company;

import java.util.Arrays;

import java.util.Scanner;

public class Main {

   public static void main(String[] args) {

       Scanner sc = new Scanner(System.in);

      while (true){

          System.out.println("A");

          System.out.println("BB");

          System.out.println("CCC");

          System.out.println("DDDD");

          System.out.println("EEEEE");

          break;

      }

   }

}

Объяснение:

решение на java на паскаль не сложно переписать я думаю.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно! Вот пример программы на языке Паскаль, которая будет выводить последовательность символов, как в вашем примере, с использованием оператора while:

pascal
program SymbolSequence; var symbol: char; count: integer; currentCount: integer; begin symbol := 'A'; count := 1; while symbol <= 'E' do begin currentCount := 1; while currentCount <= count do begin write(symbol); Inc(currentCount); end; writeln(); Inc(count); Inc(symbol); end; end.

Эта программа использует два вложенных оператора while. Внешний цикл управляет символами от 'A' до 'E', а внутренний цикл выводит символ столько раз, сколько указано в переменной count.

При запуске этой программы вы получите ожидаемый результат:

css
A BB CCC DDDD EEEEE

Надеюсь, это поможет! Если у вас возникнут дополнительные вопросы, пожалуйста, дайте мне знать.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос