Вопрос задан 14.07.2023 в 23:39.
Предмет Информатика.
Спрашивает Абрамов Лев.
1)Составить программу которая определяет в заданном числе количество единиц и троек 2)Составить
программу которая будет заменять в предложение (пре) на (при)Ответы на вопрос
        Отвечает Грабко Максим.
                
    Решение на языке Python.
1-я программа
Если имеется ввиду, что нужно определить сколько цифр 1 и 3 встречается в самом числе, то вот решение:
num = 1123123
result = len([item for item in str(num) if item in ['1', '3']])
2-я программа
text = 'предложение'
result = text.replace('пре', 'при')
            Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
                
    Для выполнения обоих задач, предположим, что вы хотите написать программу на языке программирования Python. Ниже представлены решения для каждой из задач:
- Программа для определения количества единиц и троек в заданном числе:
 
pythondef count_digits(number, digit):
    count = 0
    while number > 0:
        if number % 10 == digit:
            count += 1
        number //= 10
    return count
def main():
    try:
        num = int(input("Введите число: "))
        ones_count = count_digits(num, 1)
        threes_count = count_digits(num, 3)
        print(f"Количество единиц: {ones_count}")
        print(f"Количество троек: {threes_count}")
    except ValueError:
        print("Ошибка! Введите целое число.")
if __name__ == "__main__":
    main()
- Программа для замены подстроки "(пре)" на "(при)" в предложении:
 
pythondef replace_substring(sentence, old_substring, new_substring):
    return sentence.replace(old_substring, new_substring)
def main():
    try:
        sentence = input("Введите предложение: ")
        old_substring = "(пре)"
        new_substring = "(при)"
        updated_sentence = replace_substring(sentence, old_substring, new_substring)
        print("Обновленное предложение:", updated_sentence)
    except Exception as e:
        print("Ошибка:", str(e))
if __name__ == "__main__":
    main()
Примеры работы программ:
- Пример работы программы для определения количества единиц и троек в числе:
 
Введите число: 13315 Количество единиц: 3 Количество троек: 2
- Пример работы программы для замены подстроки "(пре)" на "(при)" в предложении:
 
Введите предложение: В преобразованных предложениях пре заменяется на при. Обновленное предложение: В приобразованных предложениях при заменяется на при.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			
Математика
 - 
			
Литература
 - 
			
Алгебра
 - 
			
Русский язык
 - 
			
Геометрия
 - 
			
Английский язык
 - 
			
Химия
 - 
			
Физика
 - 
			
Биология
 - 
			
Другие предметы
 - 
			
История
 - 
			
Обществознание
 - 
			
Окружающий мир
 - 
			
География
 - 
			
Українська мова
 - 
			
Информатика
 - 
			
Українська література
 - 
			
Қазақ тiлi
 - 
			
Экономика
 - 
			
Музыка
 - 
			
Право
 - 
			
Беларуская мова
 - 
			
Французский язык
 - 
			
Немецкий язык
 - 
			
МХК
 - 
			
ОБЖ
 - 
			
Психология
 - 
			
Физкультура и спорт
 - 
			
Астрономия
 - 
			
Кыргыз тили
 - 
			
Оʻzbek tili
 
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			