Вопрос задан 14.07.2023 в 20:11. Предмет Информатика. Спрашивает Исаева Алёна.

Напишите программу В ПИТОНЕ! Напишите программу,в которой осуществляется ввод целых цисел(ввод

осуществляется до тех пор,пока не будет введен ноль) и подсчет суммы и среднего арифметического введённых положительных чисел.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Амурская Полина.

from statistics import mean

lst = []

x = int(input())

while x != 0:

   lst.append(x)

   x = int(input())

print('Сумма -> {} Среднее -> {}'.format(sum(lst), mean(lst)))

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно! Вот пример программы на Python, которая выполняет описанные вами действия:

python
def main(): total_sum = 0 count_positive = 0 while True: try: num = int(input("Введите целое число (для завершения введите 0): ")) except ValueError: print("Некорректный ввод. Введите целое число.") continue if num == 0: break elif num > 0: total_sum += num count_positive += 1 if count_positive > 0: average = total_sum / count_positive print(f"Сумма положительных чисел: {total_sum}") print(f"Среднее арифметическое положительных чисел: {average}") else: print("Не было введено положительных чисел.") if __name__ == "__main__": main()

Как работает программа:

  1. Инициализируются переменные total_sum (сумма положительных чисел) и count_positive (количество введенных положительных чисел).
  2. Запускается бесконечный цикл while True, который будет продолжаться до тех пор, пока не будет введен 0.
  3. Внутри цикла осуществляется ввод целого числа с помощью input(). Если пользователь вводит некорректные данные, программа сообщит об ошибке и попросит ввести число заново.
  4. Если введенное число равно 0, цикл завершается с помощью break.
  5. Если введенное число больше 0, оно добавляется к общей сумме положительных чисел total_sum, и увеличивается счетчик положительных чисел count_positive.
  6. После завершения ввода, если были введены положительные числа (то есть count_positive > 0), программа вычисляет среднее арифметическое положительных чисел и выводит сумму и среднее значение на экран.
  7. Если положительные числа не были введены (count_positive == 0), программа выводит сообщение об этом.

Программа будет продолжать запрашивать ввод чисел до тех пор, пока пользователь не введет 0 для завершения.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос