
Вопрос задан 14.07.2023 в 12:44.
Предмет Информатика.
Спрашивает Раделицький Василь.
Написать программу в Паскале: Федоров, иванов и Петров выиграли вместе в лотарею арублей. Выигрыш
Иванова составил к% от всей суммы.Выигрыш Петрова - n% от суммы Иванова. Сколько Выигралкаждый?

Ответы на вопрос

Отвечает Котюк Карина.
var
a:real;
k, n:real;
begin
read(a, k ,n);
write('Иванов: ', a*(k / 100),' Петров: ',(a*(k / 100))*(n / 100),' Федоров: ', a - (a*(k / 100)+ (a*(k / 100))*(n / 100) ));
end.



Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для решения этой задачи вам нужно будет написать программу, которая принимает на вход значения к и n, а затем вычисляет выигрыши Федорова, Иванова и Петрова.
В Паскале программа может выглядеть следующим образом:
pascalprogram LotteryWinners; var totalPrize, k, n: real; ivanovPrize, petrovPrize, fedorovPrize: real; begin // Вводим общую сумму выигрыша и процент выигрыша Иванова (k) и Петрова (n) writeln('Введите общую сумму выигрыша:'); readln(totalPrize); writeln('Введите процент выигрыша Иванова:'); readln(k); writeln('Введите процент выигрыша Петрова:'); readln(n); // Вычисляем выигрыши каждого участника ivanovPrize := totalPrize * (k / 100); petrovPrize := ivanovPrize * (n / 100); fedorovPrize := totalPrize - (ivanovPrize + petrovPrize); // Выводим результаты writeln('Выигрыш Иванова составил: ', ivanovPrize:0:2, ' рублей'); writeln('Выигрыш Петрова составил: ', petrovPrize:0:2, ' рублей'); writeln('Выигрыш Федорова составил: ', fedorovPrize:0:2, ' рублей'); end.
Пользователь будет спрошен о значении общей суммы выигрыша, процента выигрыша Иванова и процента выигрыша Петрова. Затем программа вычислит выигрыши каждого участника и выведет результаты на экран.


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili