
Напишите программу в Паскале! Задать массив,состоящий из 20 элементов .Найти минимальный элемент
массива ,не кратный 7.

Ответы на вопрос

var
i, min: integer;
a: array[1..20] of integer;
begin
min:= 1000000000;
for i:= 1 to 20 do
begin
readln(a[i]);
if (a[i] < min) and (a[i] mod 7 <> 0) then
min:= a[i];
end;
writeln(min);
end.



Конечно! Вот пример программы на Паскале, который решает вашу задачу:
pascalprogram FindMinimum; const N = 20; var arr: array[1..N] of Integer; i, min: Integer; begin { Заполнение массива случайными значениями } Randomize; for i := 1 to N do arr[i] := Random(100); // Генерируем случайные числа от 0 до 99 { Инициализация минимального значения } min := MaxInt; { Поиск минимального элемента, не кратного 7 } for i := 1 to N do begin if (arr[i] < min) and (arr[i] mod 7 <> 0) then min := arr[i]; end; { Вывод результатов } Writeln('Минимальный элемент массива, не кратный 7: ', min); Readln; end.
Программа создает массив arr
из 20 элементов и заполняет его случайными числами от 0 до 99. Затем она инициализирует переменную min
максимальным целым числом (MaxInt
). Затем проходит по всем элементам массива, проверяет, является ли текущий элемент меньшим, чем текущее минимальное значение, и не кратным 7. Если условие выполняется, то значение min
обновляется. В конце программа выводит найденное минимальное значение.
Обратите внимание, что код использует встроенную функцию Randomize
, чтобы генерировать случайные числа, и Random
, чтобы получить случайное число от 0 до 99. Вы можете изменить диапазон генерируемых чисел в соответствии с вашими потребностями.


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili