Вопрос задан 14.07.2023 в 09:45.
Предмет Информатика.
Спрашивает Станіславова Настя.
Помогите составить программу по информатике. Написать программу которая определяет количество
всех двух и трехзначных чисел от 10 до 1000, которые оканчиваются на 9. Ответы на вопрос
        Отвечает Beridze Ramaz.
                
    var k,i: integer;
begin
k:=0;
for i:=10 to 999 do if i mod 10=9 then k:=k+1;
write(k);
end.
            Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
                
    Конечно, я могу помочь вам составить программу для определения количества двух- и трехзначных чисел от 10 до 1000, которые оканчиваются на 9. Вот пример программы на языке Python:
pythoncount = 0
# Проверяем каждое число в заданном диапазоне
for num in range(10, 1001):
    # Проверяем, оканчивается ли число на 9
    if num % 10 == 9:
        # Проверяем, является ли число двух- или трехзначным
        if num >= 10 and num <= 99:
            count += 1
        elif num >= 100 and num <= 999:
            count += 1
print("Количество двух- и трехзначных чисел, оканчивающихся на 9:", count)
Эта программа использует цикл for, чтобы перебрать все числа от 10 до 1000. Затем она проверяет каждое число, оканчивается ли оно на 9, и если это так, то проверяет, является ли оно двух- или трехзначным. Если число удовлетворяет обоим условиям, счетчик count увеличивается на 1. В конце программа выводит общее количество найденных чисел.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			
Математика
 - 
			
Литература
 - 
			
Алгебра
 - 
			
Русский язык
 - 
			
Геометрия
 - 
			
Английский язык
 - 
			
Химия
 - 
			
Физика
 - 
			
Биология
 - 
			
Другие предметы
 - 
			
История
 - 
			
Обществознание
 - 
			
Окружающий мир
 - 
			
География
 - 
			
Українська мова
 - 
			
Информатика
 - 
			
Українська література
 - 
			
Қазақ тiлi
 - 
			
Экономика
 - 
			
Музыка
 - 
			
Право
 - 
			
Беларуская мова
 - 
			
Французский язык
 - 
			
Немецкий язык
 - 
			
МХК
 - 
			
ОБЖ
 - 
			
Психология
 - 
			
Физкультура и спорт
 - 
			
Астрономия
 - 
			
Кыргыз тили
 - 
			
Оʻzbek tili
 
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			