Вопрос задан 14.07.2023 в 04:23.
Предмет Информатика.
Спрашивает Медведева Диана.
Даны три числа a b c Составить программу нахождения суммы нечетных чисел(не используйте сложные
команды берите Write и тд)Спасибо заранееОтветы на вопрос
Отвечает Вилкул Дмитрий.
Ответ:
program zadacha;
var a,b,c,s:real;
begin
writeln('a,b,c:');
readln(a,b,c);
s:=0;
if (a mod 2=0) then writeln('a четное число')
else s:=s+a;
if (b mod 2=0) then writeln('b четное число')
else s:=s+b;
if (c mod 2=0) then writeln('c четное число')
else s:=s+c;
writeln('s=',s);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на языке Python, которая находит сумму нечетных чисел a, b и c:
less# Ввод чисел a, b и c
a = int(input("Введите число a: "))
b = int(input("Введите число b: "))
c = int(input("Введите число c: "))
# Инициализация переменной для хранения суммы нечетных чисел
sum_odd = 0
# Проверка и добавление нечетных чисел к сумме
if a % 2 != 0:
sum_odd += a
if b % 2 != 0:
sum_odd += b
if c % 2 != 0:
sum_odd += c
# Вывод результата
print("Сумма нечетных чисел:", sum_odd)
Вы можете ввести числа a, b и c, и программа найдет их сумму, пропуская четные числа.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
