2. Написать программу, которая определяет, делителем каких чисел (среди трех введенных) является
число z. #include #include using namespace std;int main(){ int a, b, c, z; cout << "Write a,b,z"; cin >> a, b, c, z; if (a % z == 0) { cout << "z deletel` a"; } if (b % z == 0) { cout << "z deletel` b"; } if (c % z == 0) { cout << "z deletel` c"; } system("pause"); return 0;}Ответы на вопрос
Ответ:
#include <iostream>
using namespace std;
int main()
{
int a,b,c,z;
cin>>a>>b>>c>>z;
if(a%z==0)
{
cout<<a;
}
if(b%z==0)
{
cout<<b;
}
if(c%z==0)
{
cout<<c;
}
return 0;
}
Объяснение:
Программа, которую вы предложили, выглядит почти правильно, но есть одна ошибка в части считывания значений a, b, c, z с клавиатуры. Ошибка связана с использованием оператора запятой вместо оператора ввода ">>" в строке:
cppcin >> a, b, c, z;
Вместо этого, правильным способом считывания является использование оператора ">>" для каждой переменной отдельно:
cppcin >> a >> b >> c >> z;
Вот исправленная версия программы:
cpp#include <iostream>
using namespace std;
int main() {
int a, b, c, z;
cout << "Write a, b, c, z: ";
cin >> a >> b >> c >> z;
if (a % z == 0) {
cout << "z is a divisor of a." << endl;
}
if (b % z == 0) {
cout << "z is a divisor of b." << endl;
}
if (c % z == 0) {
cout << "z is a divisor of c." << endl;
}
system("pause");
return 0;
}
Теперь программа должна корректно считывать значения a, b, c, z и определять, делителем каких чисел (среди трех введенных) является число z.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
