Задание в паскале. напишите программу, которая вычесляет корни уравнения.
Ответы на вопрос
PascalABC.NET
begin
var (a, b, c) := ReadReal3('Введите a, b, c:');
if a = 0 then exit;
var D := sqr(b) - 4 * a * c;
println('Дискриминант:',D);
if D > 0 then begin
print('x1 =',(-b+sqrt(D))/(2*a));
print('x2 =',(-b-sqrt(D))/(2*a));
end
else if D = 0 then
print('x =', -b / (2 * a))
else if D < 0 then
print('Корней нет');
end.
Конечно, вот пример программы на языке Pascal, которая вычисляет корни уравнения вида ax^2 + bx + c = 0:
pascalprogram Вычисление_корней_уравнения; var a, b, c, D, x1, x2: real; begin writeln('Введите коэффициенты a, b и c уравнения ax^2 + bx + c = 0:'); readln(a, b, c); D := b * b - 4 * a * c; if D > 0 then begin x1 := (-b + sqrt(D)) / (2 * a); x2 := (-b - sqrt(D)) / (2 * a); writeln('Уравнение имеет два корня:'); writeln('x1 = ', x1:0:2); writeln('x2 = ', x2:0:2); end else if D = 0 then begin x1 := -b / (2 * a); writeln('Уравнение имеет один корень:'); writeln('x = ', x1:0:2); end else begin writeln('Уравнение не имеет действительных корней.'); end; readln; end.
Программа запрашивает у пользователя значения коэффициентов a, b и c, а затем вычисляет дискриминант D. Затем она проверяет значения D и выводит соответствующие сообщения о количестве и значениях корней уравнения.
Обратите внимание, что программа предполагает, что у вас установлена и настроена среда разработки Pascal, такая как Free Pascal или Turbo Pascal, для компиляции и выполнения программы.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
