
Составьте программу, вычисляющую скорость прямолинейного равномерного движения тела по указанным
значениям перемещения и времени, в течение которого это перемещение совершено. (Паскаль)

Ответы на вопрос

var
S,t:real;
begin
writeln('Введите длину пути');
read(S);
writeln('Введите все время пути');
read(t);
write('Скорость -> ',S/t);
end.



Вот простая программа на языке Pascal, которая вычисляет скорость прямолинейного равномерного движения по заданным значениям перемещения и времени:
pascalprogram РасчетСкорости; var перемещение, время, скорость: real; begin writeln('Введите значение перемещения (в метрах): '); readln(перемещение); writeln('Введите значение времени (в секундах): '); readln(время); скорость := перемещение / время; writeln('Скорость равна ', скорость:0:2, ' м/с'); readln; end.
Программа запрашивает у пользователя значения перемещения и времени в метрах и секундах соответственно. Затем она вычисляет скорость, разделив значение перемещения на значение времени, и выводит результат на экран. Результат выводится с округлением до двух знаков после запятой.
Пожалуйста, обратите внимание, что в Pascal использована арифметическая операция деления ("/") для вычисления скорости вещественного числа. Если перемещение и время являются целыми числами, результат деления будет округлен до ближайшего целого значения. Если вы хотите получить более точный результат, можете изменить тип переменных на double
или extended
в зависимости от версии компилятора Pascal, который вы используете.


Похожие вопросы
Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili