Вопрос задан 13.07.2023 в 23:24. Предмет Информатика. Спрашивает Беспелюхина Софья.

Составьте программу на Паскале для заполнения массива из 100 чисел случайными значениями из

диапазона от -30 до 30. Подсчитайте в этом массиве количество положительных и количество отрицательных чисел.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Тягунов Тимофей.

===== PascalABC.NET =====

begin

 var a := ArrRandom(100, -30, 30);

 a.Println;

 Writeln;

 var пол := a.Count(p -> p > 0);

 var отр := a.Count(p -> p < 0);

 Write('положительных ', пол, ', отрицательных ', отр)

end.


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно! Вот программа на языке Паскаль, которая заполняет массив из 100 чисел случайными значениями в диапазоне от -30 до 30 и подсчитывает количество положительных и отрицательных чисел:

pascal
program CountPositiveAndNegative; uses crt; var numbers: array[1..100] of integer; positiveCount, negativeCount, i: integer; begin // Инициализация генератора случайных чисел randomize; // Заполнение массива случайными значениями for i := 1 to 100 do numbers[i] := random(61) - 30; // Генерация случайного числа в диапазоне -30..30 // Подсчет положительных и отрицательных чисел positiveCount := 0; negativeCount := 0; for i := 1 to 100 do begin if numbers[i] > 0 then positiveCount := positiveCount + 1 else if numbers[i] < 0 then negativeCount := negativeCount + 1; end; // Вывод результатов writeln('Количество положительных чисел: ', positiveCount); writeln('Количество отрицательных чисел: ', negativeCount); readln; end.

Программа использует генератор случайных чисел, чтобы заполнить массив numbers случайными значениями в диапазоне от -30 до 30. Затем она проходит по массиву и подсчитывает количество положительных и отрицательных чисел. Результаты выводятся на экран.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос