 
Вопрос задан 13.07.2023 в 16:54.
Предмет Информатика.
Спрашивает Досан Аманжол.
Помогите сделать : 1)Исправить ошибки в программе , которая определяет количество отрицательных
элементов .массива:Program M;ConstN=10;VarA: Array[1..N] of integerI,k:integer;BeginFor I:=1 To N ThenA[I]:=Random100-50;if A[i]<0 do k:=k+1End;Write(k=,k);End2)Расставить в правильном порядке строчки программы , которая находит сумму всех четных элементов массива :Program M;constN=10;VarS:=0;I,s : integer;BeginIf A[i] mod 2=0 then S:=s+A[i];A[i]:= Trunc Random (101)-50;End;For I:=1 To N Do begin A:Array [1..N] of integer;Write('s=',s);End.3)Написать программу , которая посчитает сумму баллов заработанных командой из 10 человек интеллектуальном турнире по химии . Баллы для каждого участника указать рандомными числами в диапазоне от 5 до 20 0
        0
         0
        0
    Ответы на вопрос
 
        Отвечает Якимець Юля.
                
    1) Program M;
Const N=10;
Var A: Array[1..N] of integer;
I,k:integer;
Begin
For I:=1 To N do begin
A[I]:=Random100-50;
if A[i]<0 then k:=k+1
End;
Write(k=,k);
End.
2)Program M;
const N=10;
Var A:Array [1..N] of integer;
I,s : integer;
Begin
S:=0;
For I:=1 To N Do begin
A[i]:=Random (101)-50;
If A[i] mod 2=0 then S:=s+A[i];
End;
Write('s=',s);
End.
3) Program chemistry;
Const N=10;
Var A: Array[1..N] of integer;
S:integer;
Begin
For I:=1 To N do begin
A[I]:=Random(16)+5;
s:=s+a[i];
End;
Write(s=,s);
End.
 0
                    0
                     0
                    0
                 
            Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
                
    - Исправленная программа для определения количества отрицательных элементов массива:
pascalProgram M; Const N = 10; Var A: Array[1..N] of integer; I, k: integer; Begin k := 0; For I := 1 To N Do Begin A[I] := Random(101) - 50; if A[I] < 0 then k := k + 1; End; Write('k=', k); End.
- Программа для нахождения суммы всех четных элементов массива:
pascalProgram M; const N = 10; Var A: Array[1..N] of integer; S, I: integer; Begin S := 0; For I := 1 To N Do Begin A[I] := Trunc(Random(101)) - 50; if A[I] mod 2 = 0 then S := S + A[I]; End; Write('s=', S); End.
- Программа для подсчета суммы баллов заработанных командой из 10 человек на интеллектуальном турнире по химии:
pascalProgram ChemistryTournament; Const N = 10; Var Scores: Array[1..N] of integer; I, TotalScore: integer; Begin Randomize; // Initialize random number generator TotalScore := 0; // Generate random scores for each team member in the range from 5 to 20 For I := 1 To N Do Begin Scores[I] := Random(16) + 5; TotalScore := TotalScore + Scores[I]; End; // Output individual scores and total score For I := 1 To N Do WriteLn('Team member ', I, ' score: ', Scores[I]); WriteLn('Total team score: ', TotalScore); End.
Обратите внимание, что здесь используется процедура Randomize, чтобы инициализировать генератор случайных чисел. Также, при генерации случайных баллов, используется выражение Random(16) + 5, чтобы получить значения в диапазоне от 5 до 20 (включительно).
 0
                    0
                     0
                    0
                Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			