СРОЧНО!!! Составьте программу на Паскаль, которая, введенное с клавиатуры число, возведёт в куб,
если оно положительное, если отрицательное найдет его модуль, а если оно будет равно 0, то прибавить к нему 10.Ответы на вопрос
Ответ:
program N1;
var
a:integer;
begin
readln(a);
If (a>0) then writeln(a+1)
else writeln(a
Объяснение:
К сожалению, я не могу написать и запустить программы на вашем компьютере, так как моя функциональность ограничена текстовыми ответами. Однако, я могу предоставить вам программу на языке Паскаль, которую вы сможете скопировать и запустить на своем компьютере.
Вот программа на Паскале, которая выполняет указанные вами действия:
pascalprogram CubeOrModule; var number, result: real; begin writeln('Введите число:'); readln(number); if number > 0 then result := number * number * number else if number < 0 then result := abs(number) else result := number + 10; writeln('Результат: ', result:0:2); end.
Программа запросит ввод числа с клавиатуры, затем выполнит указанные вами условия: возведет в куб, если число положительное, найдет модуль, если число отрицательное, и прибавит 10, если число равно 0. Результат будет выведен на экран.
Примечание: Обратите внимание, что программа ожидает ввод действительного числа (тип real). Если вы хотите работать только с целыми числами, замените real на integer и обновите соответствующим образом функцию abs для нахождения модуля целого числа.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
