
Напишите программу которая выводит первое слово переданной её символьной строки. Слово- это
последовательность непробельных символов, ограниченная пробелами или концами строки. ПАСКАЛЬ

Ответы на вопрос

Ответ:
Адекватная версия:
PascalABC.NET
begin
var expr := Readstring();
expr.Split(' ')[0].Println;
end.
Версия "Нас так учили"
var
expression: string;
s_index: byte;
begin
s_index := 1;
readln(expression);
while expression[s_index] <> ' ' do begin
write(expression[s_index]);
s_index := s_index + 1;
end;
end.
Объяснение:
Т.к по условию слово - последовательность непробельных символов, ограниченная пробелами или концами строки, то данная программа полностью игнорирует пунктуацию и считает любой символ частью того слова, с которым он не разделён пробелом.



Для написания программы на языке Pascal, которая выводит первое слово переданной ей символьной строки, нужно использовать цикл для обхода строки и найти первое слово. Вот пример программы:
pascalprogram FirstWord; var inputString: string; firstWord: string; i, startIndex: integer; begin // Вводим строку с клавиатуры writeln('Введите строку: '); readln(inputString); // Инициализируем начальные значения переменных firstWord := ''; startIndex := 0; // Находим индекс первого непробельного символа for i := 1 to Length(inputString) do begin if not (inputString[i] in [' ', #9]) then begin startIndex := i; break; end; end; // Находим первое слово, идущее после пробелов for i := startIndex to Length(inputString) do begin if inputString[i] in [' ', #9] then begin break; end else begin firstWord := firstWord + inputString[i]; end; end; // Выводим первое слово на экран writeln('Первое слово: ', firstWord); end.
Программа будет запрашивать ввод строки и затем выводить первое слово переданный строки, игнорируя начальные пробелы. Обратите внимание, что программа не учитывает символы табуляции (заменяются на пробелы), так как в языке Pascal символы табуляции не воспринимаются как пробельные символы. Если нужно учитывать символы табуляции, можно добавить их в проверку на пробельные символы.


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili