Вопрос задан 13.07.2023 в 08:31.
Предмет Информатика.
Спрашивает Николаев Глеб.
Паскаль. Составить программу по условию: Вводится натуральное число. Проверить его кратность
каждому простому числу первого десятка. Пожалуйста, очень срочно!!!Ответы на вопрос
Отвечает Мишина Женя.
program n1;
var a,b: integer;
begin
write('Введите натуральное число: ');
readln(a);writeln('Число ',a,' - кратно: ');
for b:=1 to 9 do
if a mod b=0 then writeln(' числу ',b);
end.
Отвечает Андреев Никита.
var x,k: integer;
begin
readln(x);
for k:=1 to 9 do
if x mod k=0 then
writeln(k)
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Хорошо, вот программа на языке Паскаль, которая проверяет кратность введенного натурального числа каждому простому числу первого десятка:
pascalprogram CheckMultiplicity; var number, i: Integer; primes: array[1..10] of Integer; isMultiple: Boolean; function IsPrime(num: Integer): Boolean; var j: Integer; begin IsPrime := True; for j := 2 to Trunc(Sqrt(num)) do begin if num mod j = 0 then begin IsPrime := False; Break; end; end; end; begin WriteLn('Введите натуральное число:'); ReadLn(number); // Заполняем массив primes первыми десятью простыми числами i := 2; while i <= 30 do begin if IsPrime(i) then begin primes[(i + 1) div 2] := i; end; Inc(i); end; // Проверяем кратность введенного числа каждому простому числу for i := 1 to 10 do begin if number mod primes[i] = 0 then begin WriteLn(number, ' кратно числу ', primes[i]); isMultiple := True; end; end; if not isMultiple then WriteLn(number, ' не кратно ни одному из простых чисел первого десятка.'); end.
Программа позволяет вам ввести натуральное число и затем проверит его на кратность каждому из первых десяти простых чисел (2, 3, 5, 7, 11, 13, 17, 19, 23, 29). Если число кратно какому-либо из этих чисел, она выведет соответствующее сообщение. Если же число не кратно ни одному из простых чисел первого десятка, программа также выведет сообщение об этом.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 16
Информатика 13
Информатика 39
Информатика 160
Информатика 65
Информатика 44
Информатика 84
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
