Вопрос задан 13.07.2023 в 06:46.
Предмет Информатика.
Спрашивает Белоиваненко Светлана.
Напишите программу, которая выводит таблицу степеней 2 n (от 2 0 до 2 10). Используйте вывод чисел
в столбик по формату (х:3, у:10), где х – показатель степени, y – значение. (PascalABC) Срочно, пожалуйста!!!!Ответы на вопрос
Отвечает Усатова Полина.
Ответ:
var i,y: integer;
begin
y:=1;
writeln(0:3,y:10);
for i:= 1 to 10 do
begin
y:=y*2;
writeln(i:3,y:10);
end;
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот программа на языке PascalABC, которая выводит таблицу степеней двойки:
pascalProgram TableOfPowers; Var exponent, value: Integer; Begin For exponent := 0 To 10 Do Begin value := 2 ** exponent; WriteLn(exponent:3, value:10); End; End.
Программа выводит таблицу степеней двойки от 2^0 до 2^10 в столбик:
yaml 0 1
1 2
2 4
3 8
4 16
5 32
6 64
7 128
8 256
9 512
10 1024
Надеюсь, это поможет! Если у вас есть еще вопросы, пожалуйста, сообщите.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
