Вопрос задан 13.07.2023 в 04:07. Предмет Информатика. Спрашивает Nigmatullin Islam.

Информатика, прошу помощи в написании программы Написать программу на C# : Дан текстовый файл.

Напечатать первый символ каждой строки.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Пчелкин Андрей.

using System;

namespace ConsoleApplication

{

   class Program

   {

       static void Main(string[] args)

       {

           using (System.IO.StreamReader sr = new System.IO.StreamReader(@"C:\test1.txt"))

           {

               while (sr.Peek() > -1)

               {

                   try

                   {

                       Console.WriteLine(sr.ReadLine()[0]);

                   }

                   catch { Console.WriteLine("Пустая строка"); }

               }

           }

           Console.ReadKey();

       }

   }

}

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я помогу вам написать программу на C#, которая будет читать текстовый файл и печатать первый символ каждой строки. Для этой задачи используем стандартные библиотеки .NET.

Перед тем, как начать, убедитесь, что у вас есть текстовый файл, который вы хотите обработать. Поместите его в директорию с вашим кодом программы или предоставьте полный путь к файлу в коде программы.

Вот C# код программы:

csharp
using System; using System.IO; class Program { static void Main() { try { // Укажите путь к вашему текстовому файлу string filePath = "путь_к_файлу.txt"; // Открываем файл для чтения using (StreamReader reader = new StreamReader(filePath)) { string line; while ((line = reader.ReadLine()) != null) { // Печатаем первый символ строки if (!string.IsNullOrEmpty(line)) { char firstChar = line[0]; Console.WriteLine(firstChar); } } } } catch (FileNotFoundException) { Console.WriteLine("Файл не найден. Проверьте правильность пути к файлу."); } catch (Exception ex) { Console.WriteLine("Произошла ошибка: " + ex.Message); } } }

Важно заменить "путь_к_файлу.txt" на путь к вашему текстовому файлу. Если файл будет находиться в той же директории, что и программа, можно просто указать его имя, например, "myfile.txt".

Когда программа выполнит чтение файла и выведет первый символ каждой строки, результат будет отображен в консоли.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос