Вопрос задан 13.07.2023 в 02:16.
Предмет Информатика.
Спрашивает Русаков Влад.
Написать программу, которая вводит число. Если число двузначное, то нужно найти сумму цифр в числе.
Если число трехзначное – произвести произведение цифр числа. Если число четырехзначное – найти среднее арифметическое цифр этого числа. Если число иное – вывести запись «Введите 2-х, 3-х или 4-х значное число».Ответы на вопрос
Отвечает Ykrainets Ola.
Ответ:
- var
- x, n: integer;
- n1: real;
- begin
- Writeln('Введите число: ');
- Read(x);
- if (x > 9) and (x < 100) then
- begin
- n := (x div 10) + (x mod 10);
- Writeln('Сумма цифр равна: ', n);
- end;
- if (x > 99) and (x < 1000) then
- begin
- n := (x div 100) * ((x div 10) mod 10) * (x mod 10);
- Writeln('Произведение цифр равно: ', n);
- end;
- if (x > 999) and (x < 10000) then
- begin
- n := x div 1000 + (x div 100) mod 10 + (x div 10) mod 10 + x mod 10;
- n1 := n / 4;
- Writeln('Среднее арифметическое равно: ', n1);
- end;
- if x > 9999 then
- begin
- Writeln('Введите 2-х, 3-х или 4-х значное число');
- end;
- end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот программа на языке Python, которая реализует указанное поведение:
pythonnumber = input("Введите число: ")
if len(number) == 2:
digit_sum = int(number[0]) + int(number[1])
print("Сумма цифр числа:", digit_sum)
elif len(number) == 3:
digit_product = int(number[0]) * int(number[1]) * int(number[2])
print("Произведение цифр числа:", digit_product)
elif len(number) == 4:
digit_average = (int(number[0]) + int(number[1]) + int(number[2]) + int(number[3])) / 4
print("Среднее арифметическое цифр числа:", digit_average)
else:
print("Введите 2-х, 3-х или 4-х значное число.")
Программа запрашивает у пользователя ввод числа и затем проверяет его длину. В зависимости от длины числа выполняются различные действия: для двузначного числа находится сумма цифр, для трехзначного числа вычисляется произведение цифр, для четырехзначного числа находится среднее арифметическое цифр. Если число имеет другую длину, выводится соответствующее сообщение.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 33
Информатика 32
Информатика 51
Информатика 94
Информатика 36
Информатика 22
Информатика 36
Информатика 12
Информатика 14
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
