РЕШИТЬ ЧЕРЕЗ С++ Написать программу, которая бы по введенному номеру единицы измерения (1 —
дециметр, 2 — километр, 3 — метр, 4 — миллиметр, 5 — сантиметр) и длине отрезка L выдавала бы соответствующее значение длины отрезка в метрах.Ответы на вопрос
#include <iostream>
int main()
{
int n;
float l;
std::cin >> n >> l;
switch (n)
{
case 1:
std::cout << "Length: " << l / 10;
break;
case 2:
std::cout << "Length: " << l * 1000;
break;
case 3:
std::cout << "Length: " << l;
break;
case 4:
std::cout << "Length: " << l / 1000;
break;
case 5:
std::cout << "Length: " << l / 100;
break;
default:
break;
}
std::cout << std::endl;
system("pause");
return 0;
}
Вот пример программы на C++, которая решает вашу задачу:
cpp#include <iostream>
int main() {
int unit;
double length, convertedLength;
// Ввод номера единицы измерения
std::cout << "Введите номер единицы измерения (1 — дециметр, 2 — километр, 3 — метр, 4 — миллиметр, 5 — сантиметр): ";
std::cin >> unit;
// Ввод длины отрезка
std::cout << "Введите длину отрезка: ";
std::cin >> length;
// Конвертация длины отрезка в метры
switch (unit) {
case 1: // дециметр
convertedLength = length / 10.0;
break;
case 2: // километр
convertedLength = length * 1000.0;
break;
case 3: // метр
convertedLength = length;
break;
case 4: // миллиметр
convertedLength = length / 1000.0;
break;
case 5: // сантиметр
convertedLength = length / 100.0;
break;
default:
std::cout << "Неверный номер единицы измерения.\n";
return 0;
}
// Вывод результата
std::cout << "Длина отрезка в метрах: " << convertedLength << " м\n";
return 0;
}
При запуске программы пользователь должен будет ввести номер единицы измерения (1, 2, 3, 4 или 5) и длину отрезка. Затем программа выполнит соответствующую конвертацию и выведет результат в метрах.
Примечание: В этом примере не предусмотрена проверка на некорректный ввод пользователя (например, ввод текста вместо числа). Если введены некорректные данные, программа может дать непредсказуемый результат.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
