На языке программирования c# написать программу, которая заполняет массив случайными числами через
цикл foreach.Ответы на вопрос
Ответ:
(Для версий C# 7.2 и выше)
using System;
namespace ConsoleApp1
{
class Program
{
static void Main(string[] args)
{
Span<int> storage = stackalloc int[10];
Random r = new Random();
foreach (ref int item in storage)
item = r.Next(101)-50;
foreach (ref readonly var item in storage)
Console.Write($"{item} ");
}
}
}
Для заполнения массива случайными числами в C# можно воспользоваться классом Random. Вам потребуется создать объект этого класса и использовать его методы для генерации случайных чисел. Ниже приведен пример программы, которая заполняет массив случайными числами через цикл foreach:
csharpusing System;
class Program
{
static void Main()
{
const int arrayLength = 10; // Размер массива
int[] array = new int[arrayLength];
Random random = new Random();
// Заполнение массива случайными числами через цикл foreach
foreach (int index in array)
{
array[index] = random.Next(1, 101); // Генерация случайного числа от 1 до 100
}
// Вывод содержимого массива
Console.WriteLine("Случайные числа в массиве:");
foreach (int number in array)
{
Console.Write(number + " ");
}
Console.WriteLine(); // Переход на новую строку
}
}
В этом примере массив array размера 10 заполняется случайными числами от 1 до 100. Обратите внимание, что в C# индексация массива начинается с 0, поэтому мы используем array[index] для присвоения значения элементу массива.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
