
Вопрос задан 12.07.2023 в 21:28.
Предмет Информатика.
Спрашивает Прудник Катя.
Составить программу на паскаль .даны 2 числа.если сумма этих чисел больше 10,то первое число
возвести в квадрат,а второе увеличить на 10.В противном случае оставить числа без изменения.вывести эти числа. помогите пожалуйста.даю 25 баллов.очень нужно

Ответы на вопрос

Отвечает Быстров Ярослав.
Ответ:
var a,b: integer;
begin
write('Введите два числа: ');
readln(a,b);
if (a+b>10) then
begin
a:=a*a;
b:=b+10;
end;
writeln('a = ',a);
writeln('b = ',b);
end.



Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, я готов помочь вам с этой задачей. Вот программа на Pascal, которая выполняет указанные действия:
pascalprogram SumCheck; var num1, num2: integer; begin writeln('Введите первое число:'); readln(num1); writeln('Введите второе число:'); readln(num2); if (num1 + num2) > 10 then begin num1 := num1 * num1; num2 := num2 + 10; end; writeln('Результат:'); writeln('Первое число:', num1); writeln('Второе число:', num2); end.
Скопируйте этот код в среду разработки Pascal (например, Free Pascal) и выполните его. Программа попросит вас ввести два числа, а затем выведет измененные или оставшиеся без изменения числа в зависимости от условия.


Похожие вопросы
Топ вопросов за вчера в категории Информатика

Информатика 47

Информатика 33

Информатика 67

Информатика 18

Информатика 25

Информатика 563

Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili