
Вопрос задан 12.07.2023 в 04:24.
Предмет Информатика.
Спрашивает Шабельникова Валерия.
Написать программу, которая сравнивает 2 числа- A и B. Если A>=B, то к А прибавить 10, а если
В>А, то от В отнять 5. Помогите пожалуйста

Ответы на вопрос

Отвечает Косарев Валерий.
Ответ:
Program comparison;
begin
writeln('Введите число A');
readln(a);
writeln('Введите число B');
readln(b);
if a>b then
a+10
else
b-5
end
Объяснение:
Program comparison; - название программы.
begin - end - начало, конец программы.
между begin и end - то, что выполняется.
if, else - условные операторы.



Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на языке Python, которая выполняет указанные условия:
pythonA = float(input("Введите число A: "))
B = float(input("Введите число B: "))
if A >= B:
A += 10
else:
B -= 5
print("A =", A)
print("B =", B)
Эта программа позволяет пользователю ввести значения для переменных A и B. Затем она сравнивает их и выполняет соответствующие операции в зависимости от результата сравнения. Результаты выводятся на экран.
Пример работы программы:
makefileВведите число A: 15 Введите число B: 20 A = 15 B = 15
makefileВведите число A: 25 Введите число B: 18 A = 35 B = 13
После ввода чисел A и B программа выводит измененные значения A и B в соответствии с указанными условиями.


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili