Вопрос задан 11.07.2023 в 23:08. Предмет Информатика. Спрашивает Дорош Алевтина.

Составьте программу, которая запрашивает пароль (например, четырехзначное число) до тех пор, пока

он не будет введен правильно. Через циклы while и repeatPaskal abc​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Комиссарова Софья.

Ответ на Python:

read(a)

repeat

   read(x)

until x==a

write()

Объяснение:

Так как не сказан пароль, то 1-й ввод будет нашим паролем, а все последующие сравниваются с ним

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот программа на языке Pascal, которая будет запрашивать пароль до тех пор, пока он не будет введен правильно:

pascal
program PasswordCheck; var correctPassword: Integer; enteredPassword: Integer; begin // Задаем правильный пароль correctPassword := 1234; repeat Write('Введите пароль: '); ReadLn(enteredPassword); if enteredPassword = correctPassword then Writeln('Пароль верный. Доступ разрешен.') else Writeln('Пароль неверный. Повторите попытку.'); until enteredPassword = correctPassword; end.

Обратите внимание, что в данной программе используется цикл repeat...until, который выполняется хотя бы один раз и проверяет условие в конце цикла. Вам нужно будет заменить значение correctPassword на свой собственный пароль.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос