Вопрос задан 11.07.2023 в 22:52.
Предмет Информатика.
Спрашивает Сакаева Диана.
Составьте программу: задать массив из 10 чисел, заданных с помощью генератора случайных чисел,
найти в нем максимальный элемент (привести лишь функцию main)Ответы на вопрос
Отвечает Голявин Илья.
signed main() {
const ll n = 10;
srand(time(NULL));
ll a[n];
ll mx = -LLONG_MAX;
for(ll i = 0; i < n; i++){
a[i] = rand() % 100;
mx = max(mx,a[i]);
}
cout << mx;
}
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на языке C++ для выполнения указанных действий:
cpp#include <iostream>
#include <ctime>
#include <cstdlib>
// Функция для нахождения максимального элемента в массиве
int findMaxElement(int arr[], int size) {
int maxElement = arr[0];
for (int i = 1; i < size; ++i) {
if (arr[i] > maxElement) {
maxElement = arr[i];
}
}
return maxElement;
}
int main() {
const int arraySize = 10;
int randomArray[arraySize];
// Инициализация генератора случайных чисел
srand(time(0));
// Заполнение массива случайными числами от 1 до 100
for (int i = 0; i < arraySize; ++i) {
randomArray[i] = rand() % 100 + 1;
}
// Вывод исходного массива
std::cout << "Сгенерированный массив: ";
for (int i = 0; i < arraySize; ++i) {
std::cout << randomArray[i] << " ";
}
std::cout << std::endl;
// Нахождение максимального элемента
int maxElement = findMaxElement(randomArray, arraySize);
// Вывод результата
std::cout << "Максимальный элемент: " << maxElement << std::endl;
return 0;
}
Программа создает массив из 10 случайных чисел от 1 до 100, затем находит максимальный элемент в этом массиве и выводит его на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 17
Информатика 40
Информатика 27
Информатика 61
Информатика 10
Информатика 13
Информатика 42
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
