Составьте программу на Паскале На вход программы поступает неизвестное количество натуральных
чисел, ввод заканчивается нулём. Найти минимальное из введённых нечётных чиселОтветы на вопрос
var a, min:integer;
begin
writeln('Введите числа (цифра 0 - выход из программы)');
readln(a);
min:= a;
while(a <> 0) do begin
if (((a mod 2) = 1) and (min > a)) then
min:= a;
readln(a);
end;
writeln('Минимальное нечетное число: ', min);
end.
Конечно! Вот пример программы на языке Паскаль, которая находит минимальное из введенных нечетных чисел:
pascalprogram FindMinOddNumber; var inputNumber, minOddNumber: Integer; begin // Инициализируем минимальное нечетное число максимальным возможным значением minOddNumber := MaxInt; repeat // Считываем число с клавиатуры Readln(inputNumber); // Проверяем, является ли число нечетным и меньше текущего минимального if (inputNumber mod 2 = 1) and (inputNumber < minOddNumber) then minOddNumber := inputNumber; until inputNumber = 0; // Выводим результат if minOddNumber = MaxInt then Writeln('Нет нечетных чисел во введенных данных') else Writeln('Минимальное нечетное число: ', minOddNumber); Readln; end.
Программа будет считывать числа с клавиатуры до тех пор, пока не будет введен ноль (0). В каждой итерации цикла она проверяет, является ли текущее число нечетным и меньше текущего минимального нечетного числа. Если да, то оно становится новым минимальным нечетным числом. По окончании ввода чисел программа выводит найденное минимальное нечетное число или сообщение о том, что нечетных чисел не было введено.
Надеюсь, эта программа поможет вам!
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
