Вопрос задан 11.07.2023 в 16:20.
Предмет Информатика.
Спрашивает Кутовая Сашуля.
ПАСКАЛЬ ИНФОРМАТИКА 10 КЛАСС. Уровень B. 1) С клавиатуры вводится символьная строка. Определите,
какой символ встречается в ней чаще всего. 2) С клавиатуры вводится предложение, в котором слова разделены пробелами. Определите, сколько слов в этом предложении начинается на букву «а». 3) Напишите функцию, которая удаляет из переданной ей символьной строки все лишние пробелы, заменяя повторяющиеся пробелы на один пробел. РЕШИТЕ ПОЖАЛУЙСТА БЕЗ СЛОЖНЫХ ФУНКЦИЙ readinteger, ord, foreach, и тд не приветствуется (так как решил бы 10ти классник)Ответы на вопрос
Отвечает Кошарная Арина.
вот все программы, я все решил:



Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Давайте решим каждую задачу по порядку, используя базовые конструкции языка Pascal:
- Определение символа, который встречается чаще всего:
pascalprogram MostFrequentChar; var inputString: string; charCount: array['a'..'z'] of Integer; maxCount: Integer; mostFrequentChar: Char; i: Integer; begin writeln('Введите символьную строку:'); readln(inputString); for i := 'a' to 'z' do charCount[i] := 0; for i := 1 to Length(inputString) do if inputString[i] in ['a'..'z'] then Inc(charCount[inputString[i]]); maxCount := 0; mostFrequentChar := ' '; for i := 'a' to 'z' do if charCount[i] > maxCount then begin maxCount := charCount[i]; mostFrequentChar := i; end; writeln('Символ "', mostFrequentChar, '" встречается чаще всего, ', maxCount, ' раз.'); end.
- Определение количества слов, начинающихся на букву «а»:
pascalprogram WordsStartingWithA; var inputSentence: string; wordCount: Integer; i: Integer; begin writeln('Введите предложение:'); readln(inputSentence); wordCount := 0; i := 1; while i <= Length(inputSentence) do begin while (i <= Length(inputSentence)) and (inputSentence[i] = ' ') do Inc(i); if (i <= Length(inputSentence)) and (inputSentence[i] = 'a') then Inc(wordCount); while (i <= Length(inputSentence)) and (inputSentence[i] <> ' ') do Inc(i); end; writeln('Количество слов, начинающихся на букву "а": ', wordCount); end.
- Удаление лишних пробелов из строки:
pascalprogram RemoveExtraSpaces; var inputString, cleanedString: string; i: Integer; isSpace: Boolean; begin writeln('Введите символьную строку:'); readln(inputString); cleanedString := ''; isSpace := False; for i := 1 to Length(inputString) do begin if inputString[i] = ' ' then begin if not isSpace then begin cleanedString := cleanedString + ' '; isSpace := True; end; end else begin cleanedString := cleanedString + inputString[i]; isSpace := False; end; end; writeln('Исходная строка: "', inputString, '"'); writeln('Обработанная строка: "', cleanedString, '"'); end.
Приведенные решения предполагают, что пользователь вводит данные с клавиатуры. Каждая задача решается через базовые циклы, условные операторы и строковые операции.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 20
Информатика 23
Информатика 22
Информатика 29
Информатика 21
Информатика 20
Информатика 26
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
