
СОСТАВИТЬ ПРОГРАММУ НА ЯЗЫКЕ ПАСКАЛЬ Помогите, срочно нужна помощь Составить программу. Из 800
учащихся школы на данный момент посещают школу N человек. Определить, через сколько дней число посещающих школу составит менее половины учащихся школы, если число не больных школьников каждый день уменьшается на 10% от предыдущего дня.

Ответы на вопрос

var n,k:integer;
begin
repeat
write('Введите количество не больных школьников от 401 до 800 n=');
readln(n);
until(n>400)and(n<=800);
k:=0;
while n>400 do
begin
n:=round(n*0.9);
k:=k+1;
end;
write('Через ',k,' дн. ',' количество учащихся составит менее половины = ',n);
end.
взял отсюда: https://studassistent.ru/pascal-abc/opredelit-cherez-skolko-dnej-chislo-poseshhayushhikh-shkolu-sostavit-menee-poloviny-uchashhikhsya-shkoly-pascal-abc



Конечно, вот программа на языке Pascal, решающая данную задачу:
pascalprogram SchoolAttendance; var totalStudents, currentStudents, daysPassed: Integer; halfStudents: Real; begin Write('Введите общее количество учащихся в школе: '); Readln(totalStudents); Write('Введите начальное количество учащихся, посещающих школу: '); Readln(currentStudents); halfStudents := totalStudents / 2; daysPassed := 0; while currentStudents > halfStudents do begin currentStudents := Round(currentStudents * 0.9); // Уменьшение на 10% Inc(daysPassed); end; Writeln('Через ', daysPassed, ' дней количество учащихся, посещающих школу, составит менее половины.'); end.
Программа запрашивает общее количество учащихся в школе и начальное количество учащихся, посещающих школу. Затем она использует цикл, уменьшая количество учащихся каждый день на 10% от предыдущего дня, и подсчитывает количество дней, необходимых для того, чтобы количество учащихся стало менее половины от общего числа.


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili