 
Составить программу на Паскале для обработки одномерного массива из 10 элементов. Значения
элементов задать вводом с клавиатуры самостоятельно. Посчитать количество и напечатать номера элементов, которые больше 5. Задание 2 Составить программу на Паскале, которая удалит все буквы «о» из текста, который состоит из 6 слов. Текст нужно придумать самостоятельно. 0
        0
         0
        0
    Ответы на вопрос
 
        // PascalABC.NET
begin
// 1
var a := ReadArrInteger('Введите 10 целых чисел:', 10);
var b := a.Indices((v, i) -> v > 5);
Println('Количество:', b.Count);
Print('Номера:');
b.Select(p -> p + 1).Println;
// 2
Readln;
ReadString('Введите текст:').Replace('о', '').Print
end.
 0
                    0
                     0
                    0
                 
            Здравствуйте! Вот пример программы на языке Паскаль, который решает вашу первую задачу:
pascalprogram CountElements; const Size = 10; var numbers: array[1..Size] of Integer; i, count: Integer; begin writeln('Введите ', Size, ' целых чисел:'); for i := 1 to Size do begin write('Число ', i, ': '); readln(numbers[i]); end; writeln('Элементы, большие 5:'); count := 0; for i := 1 to Size do begin if numbers[i] > 5 then begin writeln('Номер элемента: ', i); count := count + 1; end; end; writeln('Общее количество элементов, больших 5: ', count); readln; end.
В этой программе пользователь должен ввести 10 целых чисел с клавиатуры. Затем программа проверяет каждый элемент массива и выводит номера элементов, которые больше 5. Также программа печатает общее количество элементов, удовлетворяющих условию.
А вот пример программы на языке Паскаль, решающей вашу вторую задачу:
pascalprogram RemoveLetterO; const WordCount = 6; var text: array[1..WordCount] of string; i, j: Integer; begin text[1] := 'Hello'; text[2] := 'World'; text[3] := 'OpenAI'; text[4] := 'GPT'; text[5] := 'Chat'; text[6] := 'Bot'; writeln('Исходный текст:'); for i := 1 to WordCount do begin write(text[i], ' '); end; writeln; writeln('Текст без буквы "о":'); for i := 1 to WordCount do begin for j := 1 to Length(text[i]) do begin if text[i][j] <> 'o' then begin write(text[i][j]); end; end; write(' '); end; readln; end.
В этой программе определен массив text, содержащий 6 слов. Затем программа выводит исходный текст, а затем печатает текст без буквы "о". Каждое слово выводится на отдельной строке без буквы "о".
Обратите внимание, что в обоих программах предполагается, что вы будете использовать среду разработки, поддерживающую язык Паскаль, для компиляции и запуска программы.
 0
                    0
                     0
                    0
                Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			