Вопрос задан 06.07.2023 в 14:28. Предмет Информатика. Спрашивает Киселева Елена.

НУЖНА ПОМОЩЬ!!! 1 ЗАДАЧА: Составить программу на Паскале для обработки одномерного массива из 10

элементов. Значения элементов задать вводом с клавиатуры самостоятельно. Посчитать количество и напечатать номера элементов, которые больше 5. 2 ЗАДАЧА: Составить программу на Паскале, которая удалит все буквы «о» из текста, который состоит из 6 слов. Текст нужно придумать самостоятельно. Программная реализация обязательна. На проверку нужно прислать коды программ и результаты работы в окне программы Паскаль.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Семенов Афоня.

Ответ:

1.

program z1;

var a:array [1..10] of integer;

i,k:integer;

begin

write ('Введите элементы массива через пробел и нажмите Enter ');

for i:=1 to 10 do read (a[i]);

write ('Массив: ');

for i:=1 to 10 do write (a[i],'  ');

writeln;

write ('Номера элементов больше 5: ');

for i:=1 to 10 do if a[i] > 5 then

begin

write (i,'  ');

k:=k+1

end;

writeln;

writeln ('Элементов больше 5: ',k)

end.

2.

program z2;

var s:string;

begin

readln (s);

while pos('о',s)<>0 do delete(s,pos('о',s),1);

writeln(s)

end.

Объяснение:

Смотри картинки

2. Программа удаляет только строчные русские о



0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я помогу вам с этими задачами. Вот две программы на Паскале для выполнения задач:

Программа для обработки одномерного массива:

pascal
program ArrayProcessing; var arr: array[1..10] of Integer; i: Integer; count: Integer; begin // Ввод значений массива writeln('Введите 10 элементов массива:'); for i := 1 to 10 do begin write('Элемент ', i, ': '); readln(arr[i]); end; // Подсчёт и вывод элементов, больше 5 writeln('Элементы, больше 5, находятся в ячейках:'); count := 0; for i := 1 to 10 do begin if arr[i] > 5 then begin writeln('Ячейка ', i, ': ', arr[i]); count := count + 1; end; end; writeln('Всего элементов больше 5: ', count); readln; end.

Программа для удаления букв "о" из текста:

pascal
program RemoveLetterO; var text: array[1..6] of String; i, j: Integer; begin // Ввод текста writeln('Введите 6 слов:'); for i := 1 to 6 do begin write('Слово ', i, ': '); readln(text[i]); end; // Удаление букв "о" из текста for i := 1 to 6 do begin for j := Length(text[i]) downto 1 do begin if text[i][j] = 'о' then Delete(text[i], j, 1); end; end; // Вывод обновленного текста writeln('Обновленный текст:'); for i := 1 to 6 do writeln(text[i]); readln; end.

Вы можете вставить коды программ в окно программы Паскаль и выполнить их. Результаты работы программ будут выводиться в окне программы после выполнения.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос