
Рассмотрите программы и напишите словесное условие задач. Задача 1 Program Ex1; Var a, b, c:
integer; begin readln (a, b, c); if a>b then if a>c then writeln (a) else writeln (c) else if b>c then writeln(b) else writeln(c); end. Задача 2 Program Ex2; Var a,b,c: integer; begin writeln('a=',a';b=',b); readln(a); readln(b); c := a; a := b; b := c; writeln('a=',a';b=',b); end. Задача 3 Program Ex3; Var a, b, c, S: real; begin write('Введите a : '); readln(a); write('Введите b : '); readln(b); S := (a*b)/2; writeln(S); end.

Ответы на вопрос

1. Нахождение наибольшего из трех целых чисел.
2. Поменять местами значения переменных а и b.
3. Найти площадь прямоугольного треугольника по длинам его катетов.



Задача 1: Напишите программу, которая сравнивает три целых числа (a, b и c) и выводит наименьшее из них. Если a больше b и c, то программа выводит a. Если a не больше b, но больше c, то программа выводит c. В остальных случаях программа выводит b.
Задача 2: Напишите программу, которая меняет значения двух переменных (a и b). Программа сначала выводит текущие значения a и b, затем считывает новые значения с помощью команды readln. После этого происходит обмен значениями a и b. Наконец, программа выводит новые значения a и b.
Задача 3: Напишите программу, которая запрашивает у пользователя два числа (a и b), вычисляет площадь треугольника с основанием a и высотой b, и выводит результат на экран. Площадь треугольника вычисляется по формуле S = (a * b) / 2.


Похожие вопросы
Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili