Вопрос задан 10.07.2023 в 22:03. Предмет Информатика. Спрашивает Римская Яна.

На python СРОЧНО!!!!!!!! Найди самого большого. Пользователь вводит последовательность целых

чисел (каждое число на новой строке). Если пользователь вводит 0, то последовательность заканчивается. Напишите программу, которая будет считать индекс (порядковый номер) самого большого числа. Подсказка: первое введенное число сначала является самым большим. Потом ситуация может поменяться. Мы принимаем новые числа ПОКА новое число не равно нулю. Пример входа №1: 9 8 7 6 0 Пример результата №1: 1 Пример входа №2: 1 2 3 2 1 0 Пример результата №2: 3
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Голота Валера.

Ответ:

l = list()

print("Вводите числа, 0 - остановка.")

while True:

   n = int(input())

   if n == 0:

       break;

   l.append(n)

maxInt = max(l)

print("Индекс максимального числа:" + str(l.index(maxInt)))

Объяснение:

При первом запуске я ввел максимальное число - 9, программа сказала, что индекс этого числа - 0. Почему? В языке Python нумерация списков начинается с нуля.


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример кода на Python, который решает данную задачу:

python
max_index = 0 # Индекс (порядковый номер) самого большого числа max_value = None # Значение самого большого числа # Вводим первое число, которое считаем самым большим num = int(input("Введите число (0 чтобы завершить): ")) if num != 0: max_value = num # Считываем числа и ищем самое большое index = 1 while num != 0: num = int(input("Введите число (0 чтобы завершить): ")) if num > max_value: max_value = num max_index = index index += 1 if max_value is not None: print("Индекс (порядковый номер) самого большого числа:", max_index) else: print("Вы не ввели ни одного числа.")

Программа начинает считывать числа и сравнивать их с текущим максимальным значением. Если новое число больше, то оно становится новым максимальным, и его индекс записывается в max_index. Процесс продолжается до тех пор, пока пользователь не введет 0.

Пример использования:

scss
Введите число (0 чтобы завершить): 9 Введите число (0 чтобы завершить): 8 Введите число (0 чтобы завершить): 7 Введите число (0 чтобы завершить): 6 Введите число (0 чтобы завершить): 0 Индекс (порядковый номер) самого большого числа: 1
0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос