Вопрос задан 10.07.2023 в 21:00. Предмет Информатика. Спрашивает Сокольчик Дима.

Решите задачи на Паскале: 1) Из введенной последовательсти чисел, найдите количество чисел, кратных

3. 2) Из введенной последовательности чисел, найдите трёхзначные числа. 3)Написать программу для подсчета суммы квадратов чисел от 1 до 10.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Ермакова Ульяна.

Ответ:

PascalABC.NET 3.5.1 + .NET Framework 4.7.1

#1

begin

 var A := ReadSeqInteger('enter seqeunce: ',ReadInteger('seq length: '));

 A.Where(p -> p mod 3 = 0).Count.Println;

end.

#2

begin

 var A := ReadSeqInteger('enter seqeunce: ',ReadInteger('seq length: '));

 A.Where(p -> (p>=100) and (p <= 999)).ToList.Println;

end.

#3

begin

 Range(1,10).Select(p -> p * p).sum.Println;

end.

Объяснение:

0 0
Отвечает Галиуллин Самат.

Ответ:

var n,a,b,c: integer;

begin;

read(n);//количество чисел в последовательности

for a:=1 to n do begin

 read(b);

 if (b mod 3)=0 then c:=c+1;

 end;

 write (c);

end.

var n,a,b,c: integer;

begin;

read(n);//количество чисел в последовательности

for a:=1 to n do begin

 read(b);

 if (b div 100)>0 then c:=c+1;

 end;

 write (c);

end.

var n,a,b,c: integer;

begin;

for a:=1 to 10 do begin

c:=c+(a*a);

 end;

 write (c);

end.

Объяснение:

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот решение задач на языке Паскаль:

  1. Найдите количество чисел, кратных 3:
pascal
program CountMultiplesOfThree; var n, num, count: integer; begin writeln('Введите количество чисел в последовательности:'); readln(n); count := 0; writeln('Введите числа:'); for i := 1 to n do begin readln(num); if num mod 3 = 0 then count := count + 1; end; writeln('Количество чисел, кратных 3:', count); end.
  1. Найдите трёхзначные числа:
pascal
program ThreeDigitNumbers; var n, num, count: integer; begin writeln('Введите количество чисел в последовательности:'); readln(n); count := 0; writeln('Введите числа:'); for i := 1 to n do begin readln(num); if (num >= 100) and (num <= 999) then count := count + 1; end; writeln('Количество трёхзначных чисел:', count); end.
  1. Подсчитайте сумму квадратов чисел от 1 до 10:
pascal
program SumOfSquares; var i, sum: integer; begin sum := 0; for i := 1 to 10 do begin sum := sum + i*i; end; writeln('Сумма квадратов чисел от 1 до 10:', sum); end.

Примечание: Программы написаны на языке Паскаль и предполагают, что пользователь вводит числа во время выполнения программы.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос