Напишите программу которая получает пять чисел и выводит количество одинаковых чисел в этой цепочке
(Даю 80 баллов) ПаскальОтветы на вопрос
var a: array [1..5] of integer;
i, j , count: integer;
repeated : boolean;
begin
for i := 1 to 5 do
begin
write('Введите ', i, '-e число: ');
readln(a[i]);
end;
for i := 1 to 5 do
begin
repeated := false;
for j := 1 to i - 1 do
if (a[i] = a[j]) then
repeated := true;
if repeated then continue;
count := 1;
for j:= i+1 to 5 do
if (a[i]=a[j]) then
inc(count);
writeln('Число ', a[i], ' встречается ', count,' раз');
end;
end.
Конечно, вот пример программы на языке Pascal, которая принимает пять чисел от пользователя и выводит количество одинаковых чисел в этой последовательности:
pascalprogram CountSameNumbers; var numbers: array[1..5] of Integer; countMap: array[Integer] of Integer; i, num, totalCount: Integer; begin // Инициализация массива для подсчета for i := Low(countMap) to High(countMap) do countMap[i] := 0; // Ввод чисел WriteLn('Введите пять чисел:'); for i := 1 to 5 do begin Write('Число ', i, ': '); ReadLn(numbers[i]); countMap[numbers[i]] := countMap[numbers[i]] + 1; end; // Подсчет одинаковых чисел totalCount := 0; for num := Low(countMap) to High(countMap) do begin if countMap[num] > 1 then begin WriteLn('Число ', num, ' встречается ', countMap[num], ' раза.'); totalCount := totalCount + 1; end; end; // Вывод общего количества одинаковых чисел WriteLn('Всего одинаковых чисел: ', totalCount); end.
Программа позволяет пользователю ввести пять чисел и затем выводит количество одинаковых чисел в этой последовательности, а также выводит, сколько раз каждое из этих чисел повторяется.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
