Вопрос задан 10.07.2023 в 08:22.
Предмет Информатика.
Спрашивает Грицан Дарина.
Дан одномерный массив найдите максимальный и минимальный элемент и выведите на экран , на паскале
пожалуйста Ответы на вопрос
Отвечает Ивтушенко Мария-Ивановна.
// PascalABC.NET 3.6
begin
var n := ReadInteger('Укажи длину массива:');
var a := ArrRandom(n, -99, 99);
a.Println;
Println('Максимум:', a.Max);
Println('Минимум:', a.Min)
end.

Отвечает Губеров Владислав.
begin
var n := ReadInteger('Укажи длину массива:');
var a := ArrRandom(n, -99, 99);
a.Println;
Println('Максимум:', a.Max);
Println('Минимум:', a.Min)
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример кода на языке Pascal (Free Pascal), который находит максимальный и минимальный элементы в одномерном массиве и выводит их на экран:
pascalprogram MaxMinArray; const N = 10; // Размер массива var arr: array[1..N] of Integer; i, maxElement, minElement: Integer; begin // Заполняем массив случайными числами Randomize; // Инициализируем генератор случайных чисел for i := 1 to N do arr[i] := Random(100); // Генерируем случайное число от 0 до 99 // Инициализируем начальные значения для максимального и минимального элементов maxElement := arr[1]; minElement := arr[1]; // Находим максимальный и минимальный элементы for i := 2 to N do begin if arr[i] > maxElement then maxElement := arr[i]; if arr[i] < minElement then minElement := arr[i]; end; // Выводим результаты на экран writeln('Максимальный элемент: ', maxElement); writeln('Минимальный элемент: ', minElement); end.
Этот код создает массив из 10 случайных чисел, находит максимальный и минимальный элементы с помощью цикла, а затем выводит их на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
