написать программу на языке C++ (c#) которая вводит целое чило n и массив из n целых чисел и
определяет есть ли в массиве число 30.Ответы на вопрос
Ответ:
C#
using System;
namespace ConsoleApp1
{
class Program
{
static void Main(string[] args)
{
int n;
bool b = false;
Console.Write("Введите n: ");
n = Convert.ToInt32(Console.ReadLine());
int[] A = new int[n];
Console.WriteLine("Введите массив: ");
for (int i = 0; i < n; i++)
{
A[i] = Convert.ToInt32(Console.ReadLine());
if (A[i] == 30) b = true;
}
Console.WriteLine("В массиве "+(b ? "есть" : "нет")+" числ"+ (b ? "о" : "а") + " 30");
}
}
}
Конечно, вот пример программы на языке C++, которая выполняет задачу по поиску числа 30 в массиве целых чисел:
cpp#include <iostream>
#include <vector>
int main() {
int n;
std::cout << "Введите количество элементов в массиве: ";
std::cin >> n;
std::vector<int> arr(n);
std::cout << "Введите " << n << " целых чисел: ";
for (int i = 0; i < n; ++i) {
std::cin >> arr[i];
}
bool found = false;
for (int i = 0; i < n; ++i) {
if (arr[i] == 30) {
found = true;
break;
}
}
if (found) {
std::cout << "Число 30 найдено в массиве." << std::endl;
} else {
std::cout << "Число 30 не найдено в массиве." << std::endl;
}
return 0;
}
Программа позволяет ввести количество элементов в массиве, затем вводит элементы массива и проверяет, содержит ли массив число 30.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
