Вопрос задан 10.07.2023 в 01:28. Предмет Информатика. Спрашивает Горин Геннадий.

Написать 3 программы: 1. Написать программу, которая будет считать сумму введенных с клавиатуры

чисел до тех пор, пока не будет введен ноль. 2. Написать программу (с циклом While) которая находит сумму всех четных чисел до 100. 3. Написать программу вывода квадратов всех натуральных чисел, не превосходящих данного числа N. Пример: N=50 | 1 4 9 16 25 36 49 язык Паскаль 8 класс
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Пилигузов Савелий.

1 программа:

var a, sum:integer;

begin

writeln('Введите числа (цифра 0 - выход из программы)');

sum:= 0;

readln(a);

while(a <> 0) do begin

sum:= sum + a;

readln(a);

end;

writeln('Сумма чисел = ', sum);

end.

2 программа:

var a, sum:integer;

begin

a:=0;

while(a <= 100) do begin

if (a mod 2 = 0) then

 sum:= sum + a;

a:= a + 1;

end;

writeln('Сумма четных чисел = ', sum);

end.

3 программа:

var a, i, N:integer;

begin

writeln('Введите N');

readln(N);

a:=1;

for i:=1 to N do begin

 write(a*a, ' ');

 a:= a + 1;

end;

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот примеры программ на языке Паскаль для выполнения указанных задач:

Программа 1: Считывание суммы чисел до нуля

pascal
program SumUntilZero; var num, sum: integer; begin sum := 0; repeat write('Введите число: '); readln(num); sum := sum + num; until num = 0; writeln('Сумма введенных чисел: ', sum); end.

Программа 2: Сумма четных чисел до 100 с использованием цикла While

pascal
program SumEvenNumbers; var num, sum: integer; begin sum := 0; num := 2; // начинаем с первого четного числа while num <= 100 do begin sum := sum + num; num := num + 2; // переходим к следующему четному числу end; writeln('Сумма четных чисел до 100: ', sum); end.

Программа 3: Вывод квадратов натуральных чисел до заданного числа N

pascal
program PrintSquares; var N, i: integer; begin write('Введите число N: '); readln(N); for i := 1 to N do write(i * i, ' '); end.

Пожалуйста, убедитесь, что вы правильно настроили среду разработки для языка Паскаль, чтобы эти программы могли быть выполнены успешно.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос