Даю 100 баллов!!!!Сделать программу на паскале. Задание!Написать программу, которая бы
запрашивала возраст женщины и сообщала, сколько лет ей осталось до пенсии, либо что она уже пенсионер.Ответы на вопрос
Ответ:
program jjjfd;
const n=60;
var
i: integer;
begin
writeln('Введите свой возраст');
readln(i);
if i>n then writeln ('Вы на пенсии')
else writeln('Вам осталось ', n-i, ' лет до пенсии');
readln;
end.
Объяснение:
program jjjfd;
const n=60; // константа, обозначающая возраст выхода на пенсию
var
i: integer;
begin
writeln('Введите свой возраст');
readln(i); // считываем с клавиатуры переменную i
if i>n then writeln ('Вы на пенсии') // если введённое число больше 60, печатаем, что мадам на пенсии
else writeln('Вам осталось ', n-i, ' лет до пенсии'); // в случае, если мадам ещё нет 60, печатаем сколько лет до пенсии ей осталось
readln;
end.
Конечно, я могу помочь вам написать программу на Pascal для решения этой задачи. Вот пример кода:
pascalprogram AgeToPension; var age: Integer; begin writeln('Введите возраст женщины: '); readln(age); if age >= 60 then writeln('Вы уже пенсионер.') else writeln('До пенсии осталось ', 60 - age, ' лет.'); end.
Программа будет запрашивать у пользователя возраст женщины, затем проверять этот возраст и выводить сообщение о том, сколько лет осталось до пенсии либо о том, что она уже пенсионер.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
