
Написать программу,которая бы запрашивала возраст человека и сообщала,сколько лет ему осталось до
пенсии,либо что он уже пенсионер. Мужчины уходят на пенсию в 60,а женщины в 55. Написать на языке C# очень срочно

Ответы на вопрос

using System;
class Program {
static void Main() {
Console.Write("Введите ваш пол (м/ж): ");
string sex = Console.ReadLine();
Console.Write("Введите ваш возраст: ");
int age = int.Parse(Console.ReadLine());
if (sex == "ж"){
if (age < 55)
Console.WriteLine($"Вам осталось {55 - age} лет до пенсии");
else
Console.WriteLine($"Вы пенсионер");
}
if (sex == "м"){
if (age < 60)
Console.WriteLine($"Вам осталось {60 - age} лет до пенсии");
else
Console.WriteLine($"Вы пенсионер");
}
}
}



Конечно! Вот пример программы на языке C#, которая запрашивает возраст человека и сообщает, сколько лет ему осталось до пенсии или является ли он уже пенсионером:
```csharp using System;
class Program { static void Main() { Console.Write("Введите ваш возраст: "); int age = Convert.ToInt32(Console.ReadLine());
if (age >= 60) { Console.WriteLine("Вы уже пенсионер"); } else if (age >= 55) { Console.WriteLine("Вы женщина и у вас осталось {0} лет до пенсии", 60 - age); } else { Console.WriteLine("Вы мужчина и у вас осталось {0} лет до пенсии", 65 - age); } } } ```
При запуске программы, она просит ввести ваш возраст. Затем, используя условные операторы if-else, программа проверяет возраст и выводит соответствующее сообщение о статусе пенсионера или о том, сколько лет осталось до пенсии.
Надеюсь, это поможет вам! Если у вас возникнут еще вопросы, пожалуйста, дайте мне знать.


Похожие вопросы
Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili