Вопрос задан 10.07.2023 в 00:22.
Предмет Информатика.
Спрашивает Кутуков Сергей.
Составить программу, которая, если введенное число четное, меняет его на противоположное(На языке
Pascal)Ответы на вопрос
Отвечает Сумбатова Валерия.
program pair;
var a, b:integer;
begin
writeln('Введите число');
readln(a);
if a mod 2 = 0 then
begin
a := -a;
writeln(a);
end
else
writeln('Число нечетное...');
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на языке Pascal, которая меняет введенное четное число на противоположное:
pascalprogram ChangeEvenNumber; var num: Integer; begin writeln('Введите число:'); readln(num); if num mod 2 = 0 then begin writeln('Введенное число ', num, ' является четным.'); num := -num; // Меняем знак числа writeln('Четное число было изменено на ', num); end else writeln('Введенное число ', num, ' не является четным.'); readln; end.
Программа сначала запрашивает у пользователя ввод числа, затем проверяет, является ли введенное число четным. Если да, то меняет знак числа на противоположный и выводит результат. Если число нечетное, то выводится соответствующее сообщение.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
