Вопрос задан 10.07.2023 в 00:13. Предмет Информатика. Спрашивает Оганян Михаил.

на языке программирования Python напишите программу,решающую следующую задачу:напишите функцию

calc,которая принимает 3 аргумента: первые два- это числа а третий операция которая должна быть произведена над ними.Если третий аргумент + то сложить их если - то вычесть если * то умножить если / то разделить в любом другом случае необходимо вывести фразу не известная операция
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Грудницкий Василий.

Ответ:

def welcome():

 print('Введите ваше имя!')

 name = input()

 print('Введите вашу фамилию!')

 surname = input()

 print(' ')

 print('{0} {1}, мы рады приветствовать Вас!' .format(name, surname))

 print(' ')

welcome()

def arithmetic():

 print(' ')

 print('Выберете выполняемую операцию: "+" - для сложения, "-" - для вычитания, "/" - для для деления, "*" - для умножения')

 print(' ')

 operation = input()

 print('Введите первое число:')

 number1 = int(input())

 print('Введите второе число:')

 number2 = int(input())

 if operation == '+':

   result = number1 + number2

   print('Ваш результат:', result)

 elif operation == '-':

   result = number1 - number2

   print('Ваш результат:', result)

 elif operation == '/':

   result = number1 / number2

   print('Ваш результат:', result)

 elif operation == '*':

   result = number1 * number2

   print('Ваш результат:', result)

 else:

   print('"Неизвестная операция"')    

arithmetic()

print(' ')

print('Желаете ли вы ещё воспользоваться калькулятором?')

print('Введите Y - если Да, или N - завершить работу')

answer = input()

if answer == 'Y' or 'y':

 arithmetic()

elif answer == 'N' or 'n':

 print('Досвидули мэн!')

else:

 print('Неверный символ')

Объяснение:

0 0
Отвечает Кот Саша.

def calc(a,b,operation):

   if operation == "+":

       print("{} + {} = {}".format(a,b,a+b))

   elif operation == "-":

       print("{} - {} = {}".format(a,b,a-b))

   elif operation == "*":

       print("{} * {} = {}".format(a,b,a*b))

   elif operation == "/":

       print("{} * {} = {}".format(a,b,a*b))

   else:

       print("не известная операция")

   

a = int(input("Введите 1 число: "))

b = input("Введите операцию: ")

c = int(input("Введите 2 число: "))

calc(a, c, b)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на Python, решающей данную задачу:

python
def calc(num1, num2, operation): if operation == '+': return num1 + num2 elif operation == '-': return num1 - num2 elif operation == '*': return num1 * num2 elif operation == '/': if num2 != 0: # Проверка на деление на ноль return num1 / num2 else: return "Ошибка: деление на ноль" else: return "Неизвестная операция" # Пример использования функции num1 = float(input("Введите первое число: ")) num2 = float(input("Введите второе число: ")) operation = input("Введите операцию (+, -, *, /): ") result = calc(num1, num2, operation) print("Результат:", result)

Вы можете скопировать этот код и выполнить его в своей среде разработки Python. Программа позволяет вам вводить два числа и операцию, а затем выводит результат выполнения операции или сообщение об ошибке, если операция некорректная или произошло деление на ноль.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос