
1)Чему равно значение а после выполнения программы, если с=205 b=204 Var a,b,c: integer; Begin Read
(с,b); If (с>b) or (b mod 2=0) then а:=b+2 else а:=с div 3; Writeln(a); End. 2)Напишите программу решения задачи. Дано число n. Если оно не кратно 3 или равно числу b, то вывести число n, увеличенное на 2, иначе найти 18% от числа b. 3)Напишите программу решения задачи. Дано двузначное число а. Если последняя цифра этого числа больше первой, то вывести число а, уменьшенное на 100.

Ответы на вопрос

Ответ:
Задание 2, 3 во вложении
Объяснение:
Задание 1.
Сначала вводятся переменные b и с через пробел.
Мы вводим сначала с, оно равно 205, и затем b, оно равно 204.
затем идет условие.
Если с>b или b mod 2=0
Если 205>204 или
b mod 2=0 - это означает, число b кратно 2, то есть при делении на 2 оно должно дать 0.
В нашем случае 204/2=102 , то есть число 204 кратно 2, оно поделилось на него без остатка.
Первое и второе условие сработало, а значит выполняется следующее:
a:=b+2;
То есть в переменной а мы к b прибавляем 2. И у нас выходит:
a:=204+2=206
Условие иначе у нас не работает, поэтому выводим:
Writeln(a);
Программа выведет число а
206.





- Чтобы определить значение переменной "а" после выполнения программы, необходимо знать значения переменных "с" и "b". По условию задачи, даны значения "с=205" и "b=204". Используя эти значения, давайте выполним программу по шагам:
cssVar a, b, c: integer;
Begin
Read (c, b);
If (c > b) or (b mod 2 = 0) then
a := b + 2
else
a := c div 3;
Writeln(a);
End.
Подставляем значения "с=205" и "b=204":
cssVar a, b, c: integer;
Begin
Read (205, 204);
If (205 > 204) or (204 mod 2 = 0) then
a := 204 + 2
else
a := 205 div 3;
Writeln(a);
End.
Выполняем условие "If (205 > 204) or (204 mod 2 = 0)":
cssVar a, b, c: integer;
Begin
Read (205, 204);
If (True) or (204 mod 2 = 0) then
a := 204 + 2
else
a := 205 div 3;
Writeln(a);
End.
Так как первое условие "True", то значение переменной "a" будет равно "204 + 2 = 206".
Итак, значение переменной "а" после выполнения программы при заданных значениях "с=205" и "b=204" равно 206.
- Вот программа для решения задачи:
scssVar n, b: integer;
Begin
Read(n, b);
If (n mod 3 <> 0) or (n = b) then
Writeln(n + 2)
else
Writeln(0.18 * b);
End.
- Вот программа для решения задачи:
cssVar a: integer;
Begin
Read(a);
If (a mod 10 > a div 10) then
Writeln(a - 100)
else
Writeln(a);
End.


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili