Вопрос задан 09.07.2023 в 21:30.
Предмет Информатика.
Спрашивает Савойская Маргарита.
Напишите программу, выполняя которую компьютер спрашивает год рождения человека и сравнивает с
вашим годом рождения и определяет, он(человек) старше вас или младше.(Программа языке паскаль)Ответы на вопрос
Отвечает Зарипов Богдан.
Ответ:
var x:integer;
begin
writeln('В каком году Вы родились?');
read(x);
if x>СЮДА ГОД ТВОЕГО РОЖДЕНИЯ then
writeln('Вы младше меня')
else
write('Вы старше меня');
end.
Объяснение:
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на языке Pascal, который выполняет указанное действие:
pascalprogram AgeComparison; var currentYear, birthYear, ageDifference: Integer; begin // Получаем текущий год currentYear := 2023; // Замените на текущий год // Ввод года рождения пользователя Write('Введите год вашего рождения: '); ReadLn(birthYear); // Вычисляем разницу в возрасте ageDifference := currentYear - birthYear; // Определяем, старше или младше if ageDifference > 0 then WriteLn('Вы старше меня на ', ageDifference, ' лет.') else if ageDifference < 0 then WriteLn('Вы младше меня на ', -ageDifference, ' лет.') else WriteLn('Вы и я родились в один год.'); end.
Пожалуйста, обратите внимание, что в коде выше я использовал значение 2023 для текущего года, но вам нужно будет заменить это значение на текущий год, когда будете использовать программу.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 19
Информатика 266
Информатика 34
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
