 
Вопрос задан 09.07.2023 в 16:07.
Предмет Информатика.
Спрашивает Голобородько Вова.
На программе Python. Напишите программу, которая получает с клавиатуры трёхзначное число и
записывает в логическую переменную значение «да» (True), если это все его цифры одинаковы. После этого на экран выводится ответ на вопрос: «Верно ли, что все цифры введённого числа одинаковы?» Пример: Введите число: 161 Ответ: нет. Пример: Введите число: 555 Ответ: да. 0
        0
         0
        0
    Ответы на вопрос
 
        Отвечает Красовская Мария.
                
    x = int(input())
mn = False
d = x // 100
e = x // 10 % 10
s = x % 10
if (e == d) and (e==s):
print('Верно')
mn = True
 0
                    0
                     0
                    0
                 
            Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
                
    Конечно, вот программа на Python, которая выполняет описанное вами задание:
pythondef main():
    number = int(input("Введите трёхзначное число: "))
    are_all_digits_equal = check_all_digits_equal(number)
    
    if are_all_digits_equal:
        print("Ответ: да.")
    else:
        print("Ответ: нет.")
def check_all_digits_equal(number):
    digit1 = number // 100
    digit2 = (number // 10) % 10
    digit3 = number % 10
    
    return digit1 == digit2 == digit3
if __name__ == "__main__":
    main()
Пример работы программы:
makefileВведите трёхзначное число: 161
Ответ: нет.
Введите трёхзначное число: 555
Ответ: да.
Скопируйте этот код в файл с расширением .py и выполните его с помощью интерпретатора Python.
 0
                    0
                     0
                    0
                Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			