Вопрос задан 09.07.2023 в 15:33. Предмет Информатика. Спрашивает Волк Максим.

Составить программу. Коммерсант, имея стартовый капитал k рублей, занялся торговлей, которая

ежемесячно увеличивает капитал на p%. Через сколько лет он накопит сумму s, достаточную для покупки собственного магазина? ПРОСТО ХЭЛП
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Семиглазов Илья.

var

 n,s,p:integer;

 l,k:real;

 

begin

 readln(k);

 readln(p);

 readln(s);

 n:=0;

 repeat

  l:=k*p/100;

  k:=l+k;

  n:=n+1;

 until k > s;

 write(n div 12,'Лет',n mod 12,'Месяцов');

 readln;

end.

взял отсюда: https://studassistent.ru/turbo-pascal/kommersant-imeya-startovyy-kapital-turbo-pascal

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я могу помочь вам с этой задачей. Для решения данной задачи нам потребуется найти, через сколько времени коммерсант накопит достаточную сумму для покупки магазина. Для этого нам нужно использовать формулу для сложных процентов:

A=P×(1+r100)tA = P \times \left(1 + \frac{r}{100}\right)^t,

где:

  • AA - конечная сумма (сумма для покупки магазина),
  • PP - начальный капитал (стартовый капитал),
  • rr - процент увеличения капитала ежемесячно,
  • tt - время в годах.

Мы хотим найти значение tt, когда A≥sA \geq s, где ss - сумма для покупки магазина.

Преобразуем формулу:

(1+r100)t=AP\left(1 + \frac{r}{100}\right)^t = \frac{A}{P}.

Теперь возьмем логарифм от обеих сторон:

t⋅log⁡(1+r100)=log⁡(AP)t \cdot \log{\left(1 + \frac{r}{100}\right)} = \log{\left(\frac{A}{P}\right)}.

Наконец, решим это уравнение относительно tt:

t=log⁡(AP)log⁡(1+r100)t = \frac{\log{\left(\frac{A}{P}\right)}}{\log{\left(1 + \frac{r}{100}\right)}}.

Вы можете использовать эту формулу, чтобы вычислить, через сколько лет коммерсант накопит достаточную сумму для покупки магазина. Подставьте известные величины PP, rr (в процентах), и AA, чтобы получить значение tt в годах.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос