Вопрос задан 09.07.2023 в 12:44.
Предмет Информатика.
Спрашивает Отебай Жасулан.
1)Написать программу на языке программирования Паскаль: Вывестиквадраты первых десяти
натуральныхчисел.2)Написать программу на языкепрограммирования Паскаль:Подсчитать количество двузначныхчисел, у которых сумма цифр нечетна.3)Написать программу на языкепрограммирования Паскаль: Найти наибольшую цифру натуральногочисла. С клавиатуры вводитсянатуральное число. Найти егонаибольшую цифру. (Например, введеночисло 124653. Наибольшая цифра в нем 6).РЕБЯТ,СРОЧНО НАДО.ХОТЯ БЫ ОДНО ЗАДАНИЕ ПРОШУ❤Ответы на вопрос
Отвечает Федорко Назар.
Ответ:
Задание 1:
program Hello;
var i : Integer;
begin
for i := 1 to 10 do
writeln(i * i);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, я могу помочь вам с написанием программ на языке программирования Паскаль. Вот решения ваших задач:
- Вывод квадратов первых десяти натуральных чисел:
pascalprogram Squares; var i: integer; begin for i := 1 to 10 do writeln(i, '^2 = ', i * i); end.
- Подсчет количества двузначных чисел, у которых сумма цифр нечетна:
pascalprogram CountNumbers; var count, number, digitSum: integer; begin count := 0; for number := 10 to 99 do begin digitSum := (number div 10) + (number mod 10); if digitSum mod 2 <> 0 then count := count + 1; end; writeln('Количество двузначных чисел с нечетной суммой цифр: ', count); end.
- Поиск наибольшей цифры в натуральном числе:
pascalprogram MaxDigit; var number, maxDigit, digit: integer; begin writeln('Введите натуральное число: '); readln(number); maxDigit := 0; while number > 0 do begin digit := number mod 10; if digit > maxDigit then maxDigit := digit; number := number div 10; end; writeln('Наибольшая цифра в числе: ', maxDigit); end.
Просто скопируйте каждую программу в среду разработки Паскаля и запустите ее, чтобы получить результаты. Удачи!
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
