
ДАЮ 100 БАЛЛОВ!!!!Напишите программу, которая генерирует случайное четырехзначное число и находит
сумму его цифр В ПАСКАЛЕ.

Ответы на вопрос

Ответ:
Объяснение:
program Randomizer;
const
RndLimit = 10000;
var
x, SumX : integer;
begin
SumX := 0;
// Коммент: случайное число в паскале всегда генерируется от 0 до заданного но нам необходимо от 1000, поэтому в цикле repeat...until оно будет генерироваться до тех пор, пока не станет > 999
Repeat x := Random(RndLimit) until x > 999;
writeln ('Random X= ', x);
SumX := SumX + (x div 1000) + (x mod 1000 div 100) + (x mod 1000 mod 100 div 10) + (x mod 1000 mod 100 mod 10);
writeln ('Sum = ', SumX);
end.
================ запускаем===================
Free Pascal Compiler version 2.6.2-8 [2014/01/22] for x86_64
Copyright (c) 1993-2012 by Florian Klaempfl and others
Target OS: Linux for x86-64
Compiling main.pas
Linking a.out
21 lines compiled, 0.1 sec
Random X= 5488
Sum = 25



Конечно, вот пример программы на Pascal, которая генерирует случайное четырехзначное число и находит сумму его цифр:
pascalprogram RandomNumberSum; uses SysUtils; var randomNumber, number, digitSum: Integer; begin Randomize; // Инициализация генератора случайных чисел // Генерация случайного четырехзначного числа randomNumber := Random(9000) + 1000; // Вывод сгенерированного числа Writeln('Случайное число: ', randomNumber); number := randomNumber; digitSum := 0; // Нахождение суммы цифр числа while number > 0 do begin digitSum := digitSum + number mod 10; number := number div 10; end; // Вывод суммы цифр Writeln('Сумма цифр числа: ', digitSum); Readln; // Чтобы консоль не закрылась сразу end.
Скопируйте этот код в среду программирования на Pascal (например, Free Pascal или Lazarus), скомпилируйте и запустите. Программа будет генерировать случайное четырехзначное число и выводить его, а также вычислять и выводить сумму его цифр.


Похожие вопросы
Топ вопросов за вчера в категории Информатика








Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili