1.Напишите программу . Ввести с клавиатуры 2 числа (a и b ). Если а>b то а увеличить в 2 раза.
Вывести на экран значение а 2.Напишите программу. Которая определяет введенное число с клавиатуры четное. На экране вывести надпись "число четное" или "число не четное" ПОМОГИТЕ СРОЧНО ПОЖАЛУЙСТАОтветы на вопрос
Задача
Из двух чисел с разной четностью вывести на экран нечетное число.
Решение
Описание переменных:
a, b - данные числа
Алгоритм решения задачи:
Пользователь вводит четное и нечетное число. Последовательность их ввода может быть любой. Таким образом, неизвестно какая из двух переменных (a или b) содержит нечетное число. Чтобы выяснить это, используется конструкция условного ветвления (if-else), а также операция нахождения остатка от целочисленного деления (mod).
Если результат нахождения остатка от деления значения переменной a на 2 равен нулю, значит, эта переменная содержит четное число. Тогда нечетное число находится в переменной b и его следует вывести на экран. Если же результат нахождения остатка не равен нулю, значит, a содержит нечетное число. Оно выводится в ветке else.
Программа на языке Паскаль:
var a, b: integer;
begin
writeln('Введите одно четное и одно нечетное числа');
readln(a, b);
if a mod 2 = 0 then
writeln(b,' - нечетное число')
else
writeln(a,' - нечетное число');
end.
Примеры работы программы:
Введите одно четное и одно нечетное числа
4 5
5 - нечетное число
Введите одно четное и одно нечетное числа
5 4
5 - нечетное число
Примечания:
В данном случае предполагается, что пользователь осуществляет ввод правильно, т. е. всегда вводит одно четное и одно нечетное число. Если же ввод был некорректный (два четных или два нечетных числа), то программа будет работать неправильно. В случае двух четных чисел программа выведет второе. В случае двух нечетных - первое введенное. Чтобы избежать подобных недоразумений, программу можно усовершенствовать следующим образом:
var a, b: integer;
begin
writeln('Введите одно четное и одно нечетное числа');
readln(a, b);
if (a mod 2 = 0) and (b mod 2 <> 0) then
writeln(b,' - нечетное число')
else
if (a mod 2 <> 0) and (b mod 2 = 0) then
writeln(a,' - нечетное число')
else
writeln('Некорректный ввод');
end.
В данном случае в заголовках условного оператора проверяются оба числа: одно - на четность, другое - на нечетность. Если оба будут четные, или оба будут нечетные, то сработает тело вложенного оператора else.
Конечно, вот две программы на Python, выполняющие указанные вами задачи:
Программа 1: Увеличение числа a в 2 раза, если a > b:
pythona = float(input("Введите число a: "))
b = float(input("Введите число b: "))
if a > b:
a *= 2
print("Значение a:", a)
Программа 2: Определение четности введенного числа:
pythonnum = int(input("Введите число: "))
if num % 2 == 0:
print("Число четное")
else:
print("Число не четное")
Скопируйте каждую из этих программ в среду разработки Python и выполните их. Программа 1 будет ожидать ввод двух чисел и выведет значение a после проверки и увеличения (если необходимо). Программа 2 запросит ввод числа и выведет "Число четное" или "Число не четное" в зависимости от результата проверки.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
