
Помогите, пожалуйста. Программа паскаль. написать программу: имеется целочисленный массив из 100
элементов 1) вывести на экран через запятую все элементы имеющие чётный индекс; 2) вывести на экран построчно все элементы имеющие нечётный индекс.

Ответы на вопрос

Ответ:
var anarray: array[1..100] of integer;
i: integer;
begin
Randomize;
for i := 1 to 100 do // заполняем массив рандомными числами
anarray[i] := random(100);
for i := 1 to 100 do // выводим на экран элементы массива с четным индексом
begin
if (i + 1 > 100) then Write(anarray[i])
else
if (i mod 2 = 0) then Write(anarray[i], ', ');
end;
for i := 1 to 100 do // выводим на экран элементы массива с нечетным индексом
if (i mod 2 <> 0) then WriteLn(anarray[i]);
end.



Конечно, я помогу вам написать программу на языке Паскаль, которая выполнит указанные вами задачи. Вот как может выглядеть такая программа:
pascalprogram ArrayIndexOutput; const ARRAY_SIZE = 100; var myArray: array[1..ARRAY_SIZE] of Integer; i: Integer; begin // Заполняем массив случайными значениями (для примера) for i := 1 to ARRAY_SIZE do myArray[i] := Random(100); // Генерируйте значения по вашим требованиям // Выводим элементы с четными индексами через запятую for i := 2 to ARRAY_SIZE step 2 do begin write(myArray[i]); if i < ARRAY_SIZE - 1 then write(', ') else writeln(); end; // Выводим элементы с нечетными индексами построчно for i := 1 to ARRAY_SIZE do begin if i mod 2 = 1 then writeln(myArray[i]); end; end.
Обратите внимание, что в этом примере используется генерация случайных значений для массива. Если у вас есть конкретные значения для массива, вы можете заменить эту часть кода соответствующим образом.


Похожие вопросы


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili